0

Не считывает данные с части каналов

Евгений 5 лет назад в Ошибки обновлен 5 лет назад 0
Используем внутренний сервер Modbus RTU.
Тэги считываются с устройств, являющимися ПИД-регуляторы. Один из параметров не приходит с нескольких устройств. При этом если сделать базу каналов и мнемосхему только для одного ПИД-регулятора - все данные получаются корректно.
С одного из регуляторов параметр получается корректно, но когда дублирую этот тэг и меняю у него лишь адрес на адрес этого параметра в другом модуле - данные перестают отображаться.
При выводе качества канала выводит 0.

Что можно сделать, куда смотреть?
День добрый.

Используем внутренний сервер Modbus RTU.
Тэги считываются с устройств, являющимися ПИД-регуляторы. Один из параметров не приходит с нескольких устройств. При этом если сделать базу каналов и мнемосхему только для одного ПИД-регулятора - все данные получаются корректно.
С одного из регуляторов параметр получается корректно, но когда дублирую этот тэг и меняю у него лишь адрес на адрес этого параметра в другом модуле - данные перестают отображаться.
При выводе качества канала выводит 0.

Что можно сделать, куда смотреть?

Для начала давайте поступим так, скиньте к нам на почту конфигурацию modbas которая не работает.
Это как?
Проект экспортировать и выслать, или как-то иначе можно отправить "конфигурацию modbus"?
День добрый.

Проект экспортировать и выслать, или как-то иначе можно отправить "конфигурацию modbus"?

Можно, [Имя диска\slProject\UserSetting\ModBus.xml], нужен файлик ModBus.xml.
<a href="/s/attachments/19809/1/0/bb38bfb29a828591cef238199f6c60a3.zip" class="i_item_file"><i class="icon-file"></i> ModBus.zip</a>
Разве в нём может быть что-то не так?

P.S. Можно ли разрешить добавлять на форум файлы с расширениями 7z, xml?
ModBus.zip
День добрый.

Разве в нём может быть что-то не так?

Ок. Спасибо. С файлом то наверное все в порядке)) Конфигурацию Modbus хотели посмотреть, т.е. сколько каналов и какого типа. Попробуйте как вариант уменьшить кол-во регистров в запросе. (настройка устройства в драйвере modbas)
Разве в нём может быть что-то не так?

P.S. Можно ли разрешить добавлять на форум файлы с расширениями 7z, xml?

Посмотрели Ваш файл. Пару вопросов, т.е. если добавить один регулятор все работает, добавляем ещё один перестает работать, или я не правильно понял?
Так и стоит 4 регистра в запросе. Меньше не ставится..
Так и стоит 4 регистра в запросе. Меньше не ставится..

Ок. Да да, я посмотрел уже. А по teamviewer доступ сможете дать, на месте посмотреть что и как. На расстоянии трудно "диагноз" ставить. Если ответ положительный, на почту данные для подключения скиньте.
Разве в нём может быть что-то не так?

P.S. Можно ли разрешить добавлять на форум файлы с расширениями 7z, xml?

Посмотрели Ваш файл. Пару вопросов, т.е. если добавить один регулятор все работает, добавляем ещё один перестает работать, или я не правильно понял?

Когда используется проект с одним регулятором - всё работает (делал его для устройства PID P 1.4-1 (V2.1) из файла конфига). А в реальном проекте, конфиг от которого я вам скинул - не принимаются некоторые теги из регуляторов, в частности нет данных от тегов G_PID_Ci_1.4-1_V2.1, G_PID_Ci_1.3b.3-1, но есть от G_PID_Ci_1.4-1_V1.1
Так и стоит 4 регистра в запросе. Меньше не ставится..

Ок. Да да, я посмотрел уже. А по teamviewer доступ сможете дать, на месте посмотреть что и как. На расстоянии трудно "диагноз" ставить. Если ответ положительный, на почту данные для подключения скиньте.

Доступ сможем дать ориентировочно завтра-послезавтра. Пока что ПК отключен от объекта
Доступ сможем дать ориентировочно завтра-послезавтра. Пока что ПК отключен от объекта

Ок. договорились.

Сервис поддержки клиентов работает на платформе UserEcho